ClickCease
1300 739 335

Cyber Criminals Are Actively Exploiting a WordPress Plugin Zero-Day

The Fancy Product Designer plugin — commonly used to configure visual products on WordPress, Shopify, and WooCommerce — has been compromised. Cybercriminals are actively looking for sites that use this plugin so as to exploit a recently-discovered vulnerability.

Wordpress Security

What Is a Zero-Day Exploit?

The term zero-day exploit, or just “zero-day” or “0-day”, refers to a type of vulnerability in computer software that the software vendor is aware of but that doesn’t yet have a patch or fix. During the space of time between when the exploit becomes known and when there is a patch or fix for it, the flaw makes the affected software extremely vulnerable to sinister activity.

Naturally, zero-day vulnerabilities are never intended. They are usually found where the software company least expected to find a problem. At the same time, it is up to the software company to alert affected users and to find a patch for the flaw as soon as possible. Keeping the public and/or private software users in the loop is the best thing a software company can do to help stave off complications such as leaked or corrupted data or other compromised resources.

What Is Fancy Product Designer?

Fancy Product Designer is a plugin. In other words, it’s a type of software that complements an already-existing software program with a unique feature.

In the case of Fancy Product Designer, the website explains that the plugin enables “you and your customers to design and customize any kind of product. Limited only by your imagination it gives you absolute freedom in deciding which products and which parts of the product can be customized.” As of early June, Fancy Product Designer had been installed on over 17,000 websites worldwide. These sites include WordPress sites, Shopify sites, and WooCommerce sites.

What Are Hackers Doing With the Exploit?

The bug in the Fancy Product Designer has made it possible for hackers to take advantage of Fancy Product Designer websites by deploying executable PHP files. This, in turn, allows them to entirely take over a website in any way they please.

As the majority of websites being exploited are selling something online — either a good or a service or both — most hackers will use this newfound power to obtain order information. The affected e-commerce sites will, of course, possess information such as personal names and addresses, credit card information, and in some cases, social security numbers and other personal data.

Zero-day exploits should be announced to the affected parties as soon as possible so that actions can be taken on the company level to deter hackers and possibly disable the vulnerable plugin entirely. Security preventions vary from company to company, so some affected businesses will already have security measures in place. However, others will not.

As for the Fancy Product Designer zero-day, the product designers announced that active exploitation had been going on since January 30th, 2021. A new, patched version of the plugin has been available since June 2nd, 2021, but it must be manually downloaded.

How Can I Avoid Running Into a Zero-Day Exploit That Affects My Company?

If you are a business owner or manager, chances are, you use at least one type of software to operate your company. Unfortunately, this means you’re at risk of being exploited by zero-day vulnerabilities.

These vulnerabilities crop up from time to time and are becoming relatively normal. As software and technology, in general, becomes an increasingly large part of daily life and business affairs, and as threat actors disappointingly become more adept at their craft, zero-day vulnerabilities will continue to be a problem.

The best way to combat these vulnerabilities is to start with prevention. Choose to work only with software vendors who prioritize cybersecurity. When software is as airtight as possible, zero-days are far less likely to be a problem.

Still, they do happen. To handle them well when they occur, choose your own top team of managed service providers. Again, you want professionals who prioritize cybersecurity and those who stay abreast of zero-days that may affect your company. Cutting off connections with infected software right away can prevent major problems down the line.

If you don’t currently have a reliable managed service provider you’re working with, start speaking with companies in your area today. The sooner you ensure your business’s cybersecurity, the sooner you can rest easy when it comes to zero-day vulnerabilities.

Latest Blog Posts

Watch Our Latest Tech Videos From Steadfast solutions

Subscribe To Our YouTube Channel

When Was The Last Time You Tested Your Backup?

Is Your Microsoft 365 Data Backed Up?

Are You Cybersecurity Aware? Cybersecurity Awareness In Australia

How Information Technology Enables Businesses To Do Great Things

Ransomware Recovery In Melbourne Australia | Call Steadfast at 1300 739 335

Cloud Desktop Support In Melbourne | Call Steadfast at 1300 739 335